[RESOLVED] : The issue has been fully resolved.
[UPDATE] : We have contacted our Cloud Provider to check the network. We have identified the issue to be network related on the Cloud provider side.
We are having an intermittent outage affecting incoming messages to shortcodes from Safaricom numbers.
The outage is due to a network issue on one of the databases.
We are working on fixing it.
Tentatively the service should be up and running smoothly within the next 30 minutes.