Tuesday 26 Apr 2022 01:15:00 PM

Bulk SMS UPDATE : Intermittent Delivery Delay - Safaricom - Bulk SMS

[UPDATE] : 1711 Hours

The issue has been resolved. We are monitoring performance to ensure it's back to normal performance.

[UPDATE] : 1315 Hours

Safaricom have acknowledged they are experiencing a global outage on their SMS Gateway that's causing the delays.

There's no clear ETR yet from their engineers on when they expect this to be fully resolved.

We will share any updates once received.