Thursday 4 Jun 2020 11:58:00 AM

Dashboard Bulk SMS - Outbox - Dashboard

[Identified] 04/06/2020 There's currently degraded performance on the dashboard when viewing transactions under Outbox on the SMS product.

[Fixed] 10/06/2020 The issue has since been resolved.