[Identified] 6:10pm EAT There's currently service Degradation on all SMS services on Safaricom side caused by an outage on the internet link.
Messages are being processed slower than usual as the throughput on Safaricom side is low.
[Resolved] 6:45pm EAT The issue has been fully resolved.