Monday 22 Jun 2020 03:52:00 PM

Bulk SMS Safaricom Bulk SMS - KE - Service Degradation

[Identified] 3:35pm EAT We are currently experiencing an outage on the Safaricom Kenya Bulk SMS Gateway resulting in delays.

Safaricom Engineers are working to resolve this.

[Resolved] 4:11pm EAT The issue has been resolved, messages that were in Sent status are now processed.