Wednesday 19 Aug 2020 09:35:00 AM

Voice Voice Service Outage | MTN Uganda

[Issue Identified] : We are experiencing a major outage on our Uganda Voice services. This has been escalated for quick resolution.

[Resolved: 14:05] The issue has been resolved and all Uganda services should work as expected.