[identified 2000 hours EAT]
We are currently experiencing a delay in message delivery on Safaricom SMS Gateway.
This has been escalated to Safaricom and is under investigation.
[Resolved 2210 hours EAT]
The issue was caused by a database outage on Safaricom side.