Partial Outage on Safaricom Voice in Kenya

Incident Report for Africa's Talking

Resolved

This incident has been resolved.

The provider has not yet provided an RCA but we will continue to follow up.
Posted Nov 28, 2025 - 14:05 EAT

Identified

We are experiencing partial outage for Voice in Kenya. We have notified the provider who is currently working to resolve the issue.

Apologies for the inconvinience.
Posted Nov 28, 2025 - 11:51 EAT
This incident affected: Voice.