USSD Downtime - MTN Nigeria
Incident Report for Africa's Talking
Resolved
This incident has been resolved.
Posted Jan 14, 2025 - 14:06 EAT
Update
We are continuing to investigate this issue.
Posted Jan 14, 2025 - 14:05 EAT
Investigating
We are currently unable to process MTN USSD requests in Nigeria. We are actively working to restore the service.
Posted Jan 11, 2025 - 14:18 EAT
This incident affected: USSD.