Zambia Airtel downtime
Incident Report for Africa's Talking
Resolved
This has been resolved, let us know if you experience further challenges.
Posted Nov 29, 2024 - 21:19 EAT
Identified
The connection to the provider is currently down.

We have escalated this issue to them to resolve it.

Sorry for the inconvenience caused.
Posted Nov 14, 2024 - 15:27 EAT
This incident affected: Airtime.