Safaricom Outgoing SMS Outage

Incident Report for Africa's Talking

Resolved

The incident has been resolved.
Posted May 28, 2025 - 18:16 EAT

Monitoring

The network team at Safaricom has stabilized the gateways hence the timeouts have reduced.

We are currently monitoring.
Posted May 28, 2025 - 13:17 EAT

Identified

We are currently experiencing degraded performance on Safaricom SMS Gateway.

This is intermittently affecting delivery of messages.

The issue has been escalated to Safaricom engineers for resolution.
Posted May 28, 2025 - 11:33 EAT
This incident affected: SMS (Bulk).