Airtel Kenya intermittency - airtime

Incident Report for Africa's Talking

Resolved

This incident has been resolved.
Posted Jul 28, 2025 - 10:37 EAT

Investigating

Dear client,
We are currently experiencing challenges processing transactions on Airtel.

We are working on resolving it.
Posted Jul 26, 2025 - 12:35 EAT
This incident affected: Airtime.