Intermittent Service Delivery for Voice in Kenya
Incident Report for Africa's Talking
Update
We are continuing to investigate this issue.
Posted Dec 09, 2024 - 14:29 EAT
Investigating
The downtime has been identified to have been caused by fiber fault and Safaricom's transmission team have been engaged to assist. Restoration is underway.
Posted Dec 09, 2024 - 13:27 EAT
This incident affects: Voice.