9Mobile & MTN transaction failure

Incident Report for Africa's Talking

Resolved

Both networks have been restored.

Kindly test and confirm.
Posted Mar 19, 2025 - 13:37 EAT

Identified

We have identified a problem affecting processing transactions on the two telcos.

We are working on resolving it.
Posted Mar 18, 2025 - 15:13 EAT
This incident affected: Airtime.