Challenges processing Airtime on AIRTEL KENYA
Incident Report for Africa's Talking
Resolved
This incident has been resolved.
Posted Oct 28, 2024 - 14:30 EAT
Identified
We are currently experiencing challenges processing Airtime on Airtel KE network.

This is actively being worked on and we are hoping to resolve as soon as possible.

We sincerely apologize for any inconvenience this may cause.
Posted Oct 28, 2024 - 13:19 EAT
This incident affected: Airtime.