Challenges processing Airtime on 9mobile Nigeria Network

Incident Report for Africa's Talking

Resolved

This incident has been resolved.
Posted May 09, 2025 - 19:13 EAT

Investigating

We are currently experiencing challenges processing Airtime on 9mobile Nigeria network

We are working with the relevant teams on resolving the issue soonest.

Sincere apologies for the inconvenience caused.
Posted May 09, 2025 - 18:47 EAT
This incident affected: Airtime.