Downtime on MTN & 9mobile NG Airtime service
Incident Report for Africa's Talking
Resolved
This incident has been resolved.
Posted Oct 02, 2024 - 12:25 EAT
Update
We are continuing to investigate this issue.
Posted Oct 02, 2024 - 12:01 EAT
Update
We are continuing to investigate this issue.
Posted Oct 02, 2024 - 12:00 EAT
Investigating
We are currently experiencing a downtime on Airtime NG network as a result of an issue on the providers side.
We shall advise once resolved

Apologies for the inconvenience caused.
Posted Oct 02, 2024 - 01:51 EAT
This incident affected: Airtime.