Service Degradation: Malawi TNM

Incident Report for Africa's Talking

Resolved

Please be informed that transactions towards Malawi TNM are now processing successfully.
Posted Dec 06, 2025 - 11:08 EAT

Identified

Please be informed that transactions towards Malawi TNM are currently failing with the telco.

We have raised this with the telco.

We sincerely apologise for the inconvenience.
Posted Dec 06, 2025 - 09:56 EAT
This incident affected: Airtime.