Voice Service Down Time in Tanzania

Incident Report for Africa's Talking

Resolved

This incident has been resolved.
Posted Aug 07, 2026 - 20:08 EAT

Identified

Dear Client,

We are experiencing a down time for our Voice service in Tanzania. The team has identified the cause and reached out to our service provider for quick resolution.

Apologies for the inconvinience.
Posted Aug 07, 2026 - 12:12 EAT
This incident affected: Voice.