Safaricom Kenya - Outgoing SMS Outage

Incident Report for Africa's Talking

Resolved

The issue has been resolved.
Posted Apr 30, 2026 - 15:07 EAT

Identified

We are currently experiencing an issue affecting delivery of message to Safaricom numbers in Kenya.

The issue has been escalated to Safaricom for further resolution.
Posted Apr 30, 2026 - 13:23 EAT
This incident affected: SMS (Bulk).