Airtime service degradation _Airtel KENYA

Incident Report for Africa's Talking

Resolved

This incident has been resolved.
Posted Oct 07, 2025 - 10:21 EAT

Monitoring

We are currently experiencing a service degradation on Airtel KE
Posted Oct 07, 2025 - 09:53 EAT
This incident affected: Airtime.