Challenges processing Airtime on Airtel network
Incident Report for Africa's Talking
Resolved
This incident has been resolved.
Posted Jul 22, 2024 - 11:29 EAT
Identified
We are currently experiencing challenges processing Airtime on Airtel Kenya network

We are actively working on resolving the issue.

Sincere apologies for the inconvenience caused.
Posted Jul 21, 2024 - 19:37 EAT
This incident affected: Airtime.