Unstable Voice Service in Kenya

Incident Report for Africa's Talking

Resolved

This incident has been resolved.
Posted Oct 07, 2025 - 07:14 EAT

Monitoring

A fix has been implemented by the provider and we are monitoring . So far calls are successful and the service is stable.

Thanks for your patience.
Posted Oct 06, 2025 - 20:39 EAT

Investigating

We are experiencing unstable Voice service in Kenya, our team has reached out to our provider and their engineers are working towards service restoration.

We apologize for the inconvinience.
Posted Oct 06, 2025 - 17:46 EAT
This incident affected: Voice.