Service Advisory | Planned Network Maintenance on Safaricom
Incident Report for Africa's Talking
Resolved
This incident has been resolved.
Posted Jul 15, 2024 - 09:03 EAT
Update
We are continuing to monitor for any further issues.
Posted Jul 12, 2024 - 17:22 EAT
Monitoring
Dear Valued Customer,

This is to inform you that Safaricom will be conducting network maintenance this weekend from Sunday 14th July, 2300hrs (EAT) to Monday 15th July 0500hrs (EAT). During this time, you will experience a degradation of our products and services in Kenya.

We apologise for the inconvenience and appreciate your patience during this time. Kindly run a test after the maintenance is complete, and reach out to us in case of any issues at info@africastalking.com.

Kind regards,

Africa's Talking.
Posted Jul 12, 2024 - 17:22 EAT
This incident affected: SMS (Bulk, Premium) and Airtime, Chat, Insights, Voice, USSD, Mobile Data, Sandbox.