Airtime service degradation on Airtel KE
Incident Report for Africa's Talking
Resolved
This incident has been resolved.
Posted Jul 28, 2024 - 08:42 EAT
Identified
We are currently experiencing service degradation on Airtel Kenya network.

We shall dully advise once the service stability is restored.

Sorry for the inconvenience caused
Posted Jul 27, 2024 - 14:59 EAT
This incident affected: Airtime.