USSD Downtime - MTN Rwanda

Incident Report for Africa's Talking

Resolved

The issue has been resolved.
Thank you for your patience.
Posted Apr 02, 2025 - 19:37 EAT

Identified

We are currently unable to process USSD requests on MTN.
We are actively working to restore the service.
Posted Apr 02, 2025 - 18:10 EAT
This incident affected: USSD.