The issue was identified by the provider and a fix was made immediately.
Kindly reach out to us should you face any challenges.
Posted Sep 25, 2025 - 15:46 EAT
Resolved
This incident has been resolved. Kindly reach out to us should the issue persist
Posted Sep 25, 2025 - 15:38 EAT
Identified
Dear Client, We are experiencing service interruption for our Voice service in Kenya. The team is working with our provider to have the service restored. Apologies for the inconvenience caused.