USSD Downtime - 9mobile Nigeria

Incident Report for Africa's Talking

Resolved

This incident has been resolved.
Posted Mar 10, 2025 - 15:43 EAT

Identified

We are currently unable to process 9mobile USSD requests in Nigeria. We are actively working to restore the service.
Posted Feb 28, 2025 - 13:20 EAT
This incident affected: USSD.