Airtime service outage on Telkom Kenya Network
Incident Report for Africa's Talking
Resolved
This incident has been resolved.
Posted Oct 31, 2024 - 14:56 EAT
Identified
Telkom KE is currently experiencing an outage on Airtime service.

We shall advise once the service is restored.
Posted Oct 31, 2024 - 10:58 EAT
This incident affected: Airtime.