Voice Service Downtime in Kenya

Incident Report for Africa's Talking

Resolved

This incident has been resolved.
Posted May 24, 2025 - 20:29 EAT

Investigating

We're experiencing a downtime on our Voice Service in Kenya. We're working with our service provider to fix this issue.
Posted May 24, 2025 - 15:24 EAT
This incident affected: Voice.