Service Degradation for IVORY COAST MOOV

Incident Report for Africa's Talking

Resolved

This incident has been resolved. The service is now working as expected
Posted May 27, 2025 - 10:57 EAT

Identified

Please be informed that connectivity towards Ivory Coast MTN is currently down
Posted May 25, 2025 - 10:54 EAT
This incident affected: Airtime.