Airtel KE Airtime Top-Up challenges
Incident Report for Africa's Talking
Resolved
This incident has been resolved.
Posted Dec 16, 2024 - 08:21 EAT
Identified
We are currently experiencing challenges processing Airtime on Airtel Kenya network.

We are resolute working on fixing the issue.

Sincere apologies for the inconvenience caused.
Posted Dec 16, 2024 - 06:14 EAT
This incident affected: Airtime.