Safaricom Outgoing SMS Outage

Incident Report for Africa's Talking

Resolved

This incident has been resolved.
Posted Oct 19, 2025 - 10:44 EAT

Investigating

We are currently experiencing an outage processing outgoing messages to Safaricom phone numbers.

The issue is under investigation.

We will share feedback shortly.
Posted Oct 18, 2025 - 07:30 EAT
This incident affected: SMS (Bulk).