Outage on Safaricom Incoming SMS and Delivery Reports

Incident Report for Africa's Talking

Resolved

The incident has been fully resolved.

We are receiving delivery reports and incoming messages.
Posted Jul 19, 2024 - 15:34 EAT

Monitoring

Safaricom have fixed the application issue that was causing the delivery reports and incoming messages not to be forwarded.
Posted Jul 19, 2024 - 14:32 EAT

Investigating

We are currently not receiving delivery reports and incoming SMS from Safaricom.

This has been escalated to their application engineers to resolve the issue.

For outgoing SMS, delivery is ongoing well however the status is what is affected.
Posted Jul 19, 2024 - 09:27 EAT
This incident affected: SMS (Bulk, Premium).