Airtime service downtime on AIRTEL Kenya

Incident Report for Africa's Talking

Resolved

This incident has been resolved.
Posted Dec 04, 2025 - 09:15 EAT

Identified

We are currently experiencing challenges processing Airtel Airtime transactions due to an issue on the telco side.

We shall dully advise once resolved.

Apologies for the inconvenience caused.
Posted Dec 04, 2025 - 06:58 EAT
This incident affected: Airtime.