Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 14, 2026 - 13:00 EAT
Update
We will be undergoing scheduled maintenance during this time.
Posted May 14, 2026 - 12:59 EAT
Scheduled
This is to inform you that there's a network maintenance today from 1300hrs (EAT) to 1400hrs (EAT). This will affect our products across the following markets:
USSD and Airtime - Safaricom Kenya USSD - Airtel Kenya USSD - Equitel Kenya USSD - Telkom Kenya Airtime - Telkom Kenya Airtime - MTN Uganda SMS - Moov CIV USSD and Airtime - Airtel Nigeria USSD and Airtime - Globacom Nigeria USSD - Airtel Malawi USSD and SMS - TNM Malawi USSD - Airtel, Yas, Vodacom Tanzania USSD - MTN and Glo Nigeria Airtime - MTN, Zamtel Zambia Airtime - Glo Nigeria Payments (MPesa Topups) - Safaricom Kenya
We apologise for the inconvenience and appreciate your patience during this time. Kindly run a test after the maintenance is complete, and reach out to us in case of any issues at info@africastalking.com.
Kind regards, Africa's Talking.
Posted May 14, 2026 - 12:53 EAT
This scheduled maintenance affected: SMS (Bulk) and Airtime, USSD.