Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 09, 2025 - 21:00 EAT
Scheduled
Dear Valued Customer,
This is to inform you that there's a planned network maintenance this Thursday 9th October, from 2100 hrs (EAT). The maintenance is anticipated to take approximately 30 minutes and may cause temporary downtimes for the following products:
We apologise for the inconvenience and appreciate your patience during this time. Kindly run a test after the maintenance is complete, and reach out to us in case of any issues at info@africastalking.com.
Kind regards, Africa's Talking.
Posted Oct 08, 2025 - 09:25 EAT
This scheduled maintenance affected: Airtime and USSD.