Airtime service downtime on Airtel Kenya

Incident Report for Africa's Talking

Resolved

This incident has been resolved.
Posted Dec 30, 2025 - 17:08 EAT

Identified

Airtel is currently experiencing a network issue which is affecting airtime delivery.

The team is actively working on resolving the issue.

Apologies for the inconvenience caused.
Posted Dec 30, 2025 - 14:56 EAT
This incident affected: Airtime.