Challenges processing Airtime on Airtel Kenya network

Incident Report for Africa's Talking

Resolved

This incident has been resolved.
Posted Oct 24, 2024 - 12:15 EAT

Identified

We are currently experiencing challenges processing airtime on Airtel Kenya network.

We are actively working on resolving the issue.

We regret the convenient caused.
Posted Oct 19, 2024 - 17:55 EAT
This incident affected: Airtime.