Airtime Service Downtime in Ghana, Ethiopia, Malawi,Zimbabwe, Mozambique - Ghana is restored

Incident Report for Africa's Talking

Update

Ghana has been restored.

Kindly resume processing your transactions
Posted Dec 20, 2024 - 16:05 EAT

Identified

We are experiencing service downtime in these markets. We are working to resume the service.
Posted Oct 15, 2024 - 11:26 EAT

Investigating

We are experiencing service downtime in these markets. We are working to resume the service.
Posted Oct 15, 2024 - 11:09 EAT
This incident affects: Airtime.