Voice Service Downtime on Safaricom, Kenya

Incident Report for Africa's Talking

Resolved

The SIP connection issues previously impacting Safaricom SBC routes have been resolved. All services are now operating normally. Thank you for your patience while we resolved this matter.
Posted Mar 03, 2026 - 17:21 EAT

Investigating

We are currently investigating this issue.
Posted Mar 03, 2026 - 14:40 EAT
This incident affected: Voice.