Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 11, 2024 - 20:30 EAT
Scheduled
Dear Valued Customer,
This is to inform you that there's a planned network maintenance from Friday 11th October, 2030hrs (EAT) to Saturday 12th October, 0200hrs (EAT). This will affect our products across the following markets:
We apologise for the inconvenience and appreciate your patience during this time. Kindly run a test after the maintenance is complete, and reach out to us in case of any issues at info@africastalking.com.
Kind regards,
Africa's Talking.
Posted Oct 02, 2024 - 15:16 EAT
This scheduled maintenance affected: SMS (Bulk) and Airtime, USSD.