Challenges processing Airtime on Airtel Kenya Network
Incident Report for Africa's Talking
Resolved
This incident has been resolved.
Posted Jan 04, 2025 - 18:28 EAT
Identified
We are currently experiencing challenges processing Airtime on Airtel Kenya network

We are working with the relevant teams on resolving the issue soonest.

Sincere apologies for the inconvenience caused.
Posted Jan 03, 2025 - 21:29 EAT
This incident affected: Airtime.