Partial Outage for Voice in Kenya

Incident Report for Africa's Talking

Resolved

This incident has been resolved.
Posted Jun 16, 2026 - 19:21 EAT

Identified

Dear Client,

We are experiencing intermittent delivery for the Voice service in Kenya. We have reached out to the provider and the issue is being worked on.

Apologies for the inconvinience.
Posted Jun 16, 2026 - 09:48 EAT
This incident affected: Voice.