Voice Downtime In Kenya

Incident Report for Africa's Talking

Resolved

This incident has been resolved.
Posted Jun 14, 2025 - 23:21 EAT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 14, 2025 - 10:40 EAT

Identified

We are currently facing intermittent service delivery for Voice in Kenya. The Team is currently working with the provider to have the issue resolved as a matter of priority.

Apologies for the inconvinience.
Posted Jun 14, 2025 - 09:39 EAT
This incident affected: Voice.