Intermittent Service Delivery for USSD in South Africa

Incident Report for Africa's Talking

Resolved

This incident has been resolved.
Posted Nov 14, 2025 - 11:06 EAT

Investigating

We are currently unable to process USSD requests on Glo

We are actively working to restore the service.
Posted Nov 12, 2025 - 14:48 EAT
This incident affected: USSD.