Challenges processing airtime on Airtel Kenya
Incident Report for Africa's Talking
Resolved
This incident has been resolved.
Posted Nov 10, 2024 - 17:07 EAT
Identified
We are currently experiencing a hitch affecting processing of airtime on Airtel network.

We are actively working on revolving the issue.

We regret the inconvenience caused.
Posted Nov 10, 2024 - 16:54 EAT
This incident affected: Airtime.