Airtel KE airtime degradation

Incident Report for Africa's Talking

Resolved

The issue has been resolved.

Please let us know if you experience further challenges
Posted Aug 15, 2024 - 11:31 EAT

Investigating

We are currently experiencing a service degration on Airtel KE airtime.

We are working with the provider to restore it.

Sorry for the inconvenience caused
Posted Aug 14, 2024 - 17:05 EAT
This incident affected: Airtime.