Service degradation - Telkom Kenya

Incident Report for Africa's Talking

Resolved

This incident has been resolved.
Posted Sep 15, 2025 - 11:15 EAT

Identified

We are having challenges processing transactions on this network.

We are working to resolve it.

------------------------
Update:
The issue has been resolved. We are now processing transactions on this network.
Sorry for the inconvenience caused.
Posted Sep 13, 2025 - 20:46 EAT
This incident affected: Airtime.