Voice Service Interruptions in Nigeria on 0708... Series

Incident Report for Africa's Talking

Resolved

This incident has been resolved.
Posted Apr 01, 2025 - 12:10 EAT

Investigating

We are experiencing a partial outage in Voice Nigeria, where calls from 0708...series are dropping. We are investigating this issue.
Posted Mar 28, 2025 - 14:55 EAT
This incident affected: Voice.